]>
https://gitweb.dealii.org/ - dealii.git/log
Martin Kronbichler [Mon, 7 Nov 2016 11:41:25 +0000 (12:41 +0100)]
Initialize all variables in MatrixFreeFunctions::ShapeInfo
Denis Davydov [Mon, 7 Nov 2016 06:24:12 +0000 (07:24 +0100)]
Merge pull request #3485 from bangerth/remove-duplicate-variable
Remove the FE_DGPNonparametric::degree variable.
Wolfgang Bangerth [Mon, 7 Nov 2016 06:20:51 +0000 (23:20 -0700)]
Remove the FE_DGPNonparametric::degree variable.
It shadows the variable of same name in the base class, and always has the
same value.
Denis Davydov [Mon, 7 Nov 2016 05:11:36 +0000 (06:11 +0100)]
Merge pull request #3476 from kronbichler/matrix_free_improvements
Matrix-free operator cleanup
Martin Kronbichler [Sun, 6 Nov 2016 19:52:57 +0000 (20:52 +0100)]
Initialize variables
Martin Kronbichler [Sun, 6 Nov 2016 16:07:39 +0000 (17:07 +0100)]
Merge pull request #3481 from drwells/pvs-block-vector-iterator
Clarify the signature of a copy constructor.
Martin Kronbichler [Sun, 6 Nov 2016 16:07:14 +0000 (17:07 +0100)]
Merge pull request #3480 from drwells/pvs-block-matrix-array-entry
Add (private) BlockMatrixArray::Entry::operator=.
Martin Kronbichler [Sun, 6 Nov 2016 16:05:19 +0000 (17:05 +0100)]
Require Trilinos for test
Martin Kronbichler [Sat, 5 Nov 2016 21:24:17 +0000 (22:24 +0100)]
Make DiagonalMatrix member of MFOps::Base a shared_ptr
Martin Kronbichler [Mon, 31 Oct 2016 19:48:09 +0000 (20:48 +0100)]
Let MatrixFreeOperators::Base fix the ghost part of a vector
Martin Kronbichler [Mon, 31 Oct 2016 19:47:22 +0000 (20:47 +0100)]
Avoid warnings about deprecated class
Martin Kronbichler [Mon, 31 Oct 2016 19:46:45 +0000 (20:46 +0100)]
Avoid using deprecated functions in initialization
Martin Kronbichler [Mon, 31 Oct 2016 19:45:58 +0000 (20:45 +0100)]
Insert option for using Chebyshev as solver
David Wells [Sun, 6 Nov 2016 13:47:17 +0000 (08:47 -0500)]
Clarify the signature of a copy constructor.
PVS studio claims that we do not implement a copy constructor for this
iterator. It is likely that (unnecessarily) including the template
arguments here confused PVS studio, so remove them.
David Wells [Sun, 6 Nov 2016 12:46:52 +0000 (07:46 -0500)]
Add (private) BlockMatrixArray::Entry::operator=.
This class implements a (destructive) copy constructor more or less so
that one can use it with std::vector::push_back, so it should disable
operator=.
This fixes a warning caught by PVS studio.
Denis Davydov [Sun, 6 Nov 2016 05:32:57 +0000 (06:32 +0100)]
Merge pull request #3479 from bangerth/clarify-variable-name
Use 'order' instead of 'degree' in FE_RannacherTurek.
Denis Davydov [Sun, 6 Nov 2016 05:31:29 +0000 (06:31 +0100)]
Merge pull request #3478 from bangerth/initialize-variables-5
Initialize members of IndexSet::Range.
Denis Davydov [Sun, 6 Nov 2016 05:31:04 +0000 (06:31 +0100)]
Merge pull request #3477 from bangerth/add-Exception-copy-constructor
Add a (disabled) copy operator to ExceptionBase.
Wolfgang Bangerth [Sun, 6 Nov 2016 03:35:26 +0000 (21:35 -0600)]
Use 'order' instead of 'degree' in FE_RannacherTurek.
The existing 'degree' member variable shadows a member of the base class,
but worse it does not have the same semantics: the former pertains to the
order of the element, the latter to the polynomial degree. Fix this.
Wolfgang Bangerth [Sun, 6 Nov 2016 02:50:01 +0000 (20:50 -0600)]
Initialize members of IndexSet::Range.
David Wells [Sun, 6 Nov 2016 02:12:49 +0000 (22:12 -0400)]
Merge pull request #3451 from bangerth/fix-scopes
Fix the scopes of variables.
Wolfgang Bangerth [Sun, 6 Nov 2016 01:57:59 +0000 (19:57 -0600)]
Add a (disabled) copy operator to ExceptionBase.
David Wells [Sun, 6 Nov 2016 01:03:35 +0000 (21:03 -0400)]
Merge pull request #3475 from drwells/gcc4-fix
Fix compilation with some matrix free tests.
Wolfgang Bangerth [Fri, 4 Nov 2016 13:16:02 +0000 (07:16 -0600)]
Fix the scopes of variables.
The current version has variables in outer scopes that are assigned the addresses
of local variables in inner scopes. These addresses are not actually used in the
outer scope after we leave the inner scope, but it's a bad idea anyway. Move
the declaration of the pointers to the inner scopes where they are actually
used.
David Wells [Sat, 5 Nov 2016 19:33:30 +0000 (15:33 -0400)]
Fix compilation with some matrix free tests.
This fixes a compilation error with GCC 4.8:
error: no match for ‘operator=’
(operand types are ‘boost::shared_ptr<dealii::Table<2, dealii::VectorizedArray<double> > >’ and ‘long int’)
scalar_coefficient = NULL;
^
Martin Kronbichler [Sat, 5 Nov 2016 19:14:00 +0000 (20:14 +0100)]
Merge pull request #3473 from drwells/pvs-precondition-block
Pvs precondition block
David Wells [Sat, 5 Nov 2016 17:56:26 +0000 (13:56 -0400)]
Merge pull request #3474 from kronbichler/master
Return vector partitioner by reference
David Wells [Sat, 5 Nov 2016 14:16:45 +0000 (10:16 -0400)]
Use different names for function arguments.
PreconditionBlock already has two members named 'permutation' and
'inverse_permutation' so this makes things a bit clearer.
I applied the same naming scheme to a separate function where previously
the variables were called 'p' and 'i'.
Daniel Arndt [Sat, 5 Nov 2016 17:22:36 +0000 (18:22 +0100)]
Merge pull request #3454 from masterleinad/address_3427
Make casts explicit, initialize all variables
Martin Kronbichler [Sat, 5 Nov 2016 16:40:01 +0000 (17:40 +0100)]
Return vector partitioner by reference
David Wells [Sat, 5 Nov 2016 14:15:30 +0000 (10:15 -0400)]
Initialize a member variable of PreconditionBlock.
This is the default value used by the AdditionalData struct.
Martin Kronbichler [Sat, 5 Nov 2016 15:35:11 +0000 (16:35 +0100)]
Merge pull request #3472 from bangerth/rename-variables-2
Rename a few local variables to avoid ambiguity with member variables.
David Wells [Sat, 5 Nov 2016 15:33:27 +0000 (11:33 -0400)]
Merge pull request #3471 from bangerth/initialize-variables
Initialize member variables.
David Wells [Sat, 5 Nov 2016 14:14:31 +0000 (10:14 -0400)]
Remove unused method arguments.
This is a protected method which is always called with two member
variables with identical names as the function arguments.
This was caught by PVS studio.
Wolfgang Bangerth [Sat, 5 Nov 2016 13:49:11 +0000 (07:49 -0600)]
Rename a few local variables to avoid ambiguity with member variables.
The `MGLevelGlobalTransfer` class has member variables `copy_indices_*` but in the
`fill_and_communicate_copy_indices()` member function also allocates local variables
of the same name. Rename these to make the distinction clearer.
While there, also initialize a few member variables in the constructor of a local
class.
Wolfgang Bangerth [Sat, 5 Nov 2016 13:21:42 +0000 (07:21 -0600)]
Initialize member variables.
Martin Kronbichler [Sat, 5 Nov 2016 12:23:51 +0000 (13:23 +0100)]
Merge pull request #3469 from drwells/pvs-dof-info-initialize
Initialize two DoFInfo fields.
Wolfgang Bangerth [Sat, 5 Nov 2016 03:56:41 +0000 (21:56 -0600)]
Merge pull request #3456 from drwells/pvs-sparsity-repeated-expression
Remove some repeated subexpressions.
Wolfgang Bangerth [Sat, 5 Nov 2016 03:55:35 +0000 (21:55 -0600)]
Merge pull request #3468 from drwells/pvs-integration-info-initialize
Initialize an IntegrationInfo field.
David Wells [Sat, 5 Nov 2016 02:46:45 +0000 (22:46 -0400)]
Initialize two DoFInfo fields.
These are the same values used in the reinit function.
David Wells [Sat, 5 Nov 2016 02:24:39 +0000 (22:24 -0400)]
Initialize an IntegrationInfo field.
This number is correctly filled by IntegrationInfo::initialize, but this
way it starts out with a bogus value (instead of an undefined one).
David Wells [Sat, 5 Nov 2016 02:11:06 +0000 (22:11 -0400)]
Merge pull request #3462 from bangerth/rename-variables-2
Rename some variables.
David Wells [Sat, 5 Nov 2016 01:40:58 +0000 (21:40 -0400)]
Merge pull request #3463 from bangerth/rename-variables-3
Rename some variables.
David Wells [Sat, 5 Nov 2016 00:43:58 +0000 (20:43 -0400)]
Merge pull request #3464 from bangerth/rename-functions-and-variables
Rename local variables with names equal to members of the base class.
David Wells [Fri, 4 Nov 2016 23:58:32 +0000 (19:58 -0400)]
Merge pull request #3465 from bangerth/clarify-code
Clarify the intent of a piece of code.
David Wells [Fri, 4 Nov 2016 23:21:07 +0000 (19:21 -0400)]
Merge pull request #3466 from bangerth/initialize-variable-5
Initialize a member variable of LogStream.
David Wells [Fri, 4 Nov 2016 22:46:14 +0000 (18:46 -0400)]
Remove a repeated subexpression.
This was caught by PVS studio.
David Wells [Fri, 4 Nov 2016 22:44:49 +0000 (18:44 -0400)]
Prefer SparsityPattern::empty() to ad hoc checks.
Martin Kronbichler [Fri, 4 Nov 2016 22:25:06 +0000 (23:25 +0100)]
Merge pull request #3467 from bangerth/initialize-variable-6
Initialize member variables.
David Wells [Fri, 4 Nov 2016 22:24:03 +0000 (18:24 -0400)]
Merge pull request #3459 from bangerth/rename-arguments
Rename function arguments.
David Wells [Fri, 4 Nov 2016 22:13:41 +0000 (18:13 -0400)]
Merge pull request #3458 from bangerth/rename-variables
Rename some variables.
Wolfgang Bangerth [Fri, 4 Nov 2016 20:38:24 +0000 (14:38 -0600)]
Initialize member variables.
Wolfgang Bangerth [Fri, 4 Nov 2016 20:35:12 +0000 (14:35 -0600)]
Initialize a member variable of LogStream.
The variable really was never initialized, even though some
output depended on it. I suspect that it just happened to always
be initialized to 'false'. Make this explicit.
Wolfgang Bangerth [Fri, 4 Nov 2016 20:31:09 +0000 (14:31 -0600)]
Clarify the intent of a piece of code.
The code uses integer division, followed by a double precision multiplication.
It is admittedly not immediately obvious what it is supposed to do. Clarify
that we really mean the integer division.
Wolfgang Bangerth [Fri, 4 Nov 2016 20:22:25 +0000 (14:22 -0600)]
Rename local variables with names equal to members of the base class.
This is certainly confusing.
While there, notice that the functions that *compute* quadrature points
and weights are called 'set_*', but are 'const'. That makes no sense.
In fact, they just compute and return these values, so call them
'get_*' instead.
Wolfgang Bangerth [Fri, 4 Nov 2016 20:16:13 +0000 (14:16 -0600)]
Rename some variables.
There are variables of the same name in the base class. Avoid the
confusion of having similarly named variables in the local scope.
Wolfgang Bangerth [Fri, 4 Nov 2016 20:14:13 +0000 (14:14 -0600)]
Rename some variables.
There are variables of the same name in the base class. Avoid the
confusion of having similarly named variables in the local scope.
Matthias Maier [Fri, 4 Nov 2016 18:44:42 +0000 (13:44 -0500)]
Merge pull request #3450 from bangerth/fix-warning
No need for double parentheses.
Matthias Maier [Fri, 4 Nov 2016 18:44:28 +0000 (13:44 -0500)]
Merge pull request #3446 from bangerth/fix-DataOutRotation-build_one_patch
Rename a function argument.
Matthias Maier [Fri, 4 Nov 2016 18:43:24 +0000 (13:43 -0500)]
Merge pull request #3453 from bangerth/initialize-variables-4
Initialize member variables.
Matthias Maier [Fri, 4 Nov 2016 18:41:03 +0000 (13:41 -0500)]
Merge pull request #3338 from kalj/check-for-compute-capability
Check for compute capability
Denis Davydov [Fri, 4 Nov 2016 18:34:42 +0000 (19:34 +0100)]
Merge pull request #3461 from kalj/patch-1
Use a single if block
Karl Ljungkvist [Fri, 4 Nov 2016 18:30:45 +0000 (19:30 +0100)]
Use a single if block
Fix warning from PVS about two if blocks with identical condition. Fixes #3369.
Wolfgang Bangerth [Fri, 4 Nov 2016 16:49:55 +0000 (10:49 -0600)]
Rename function arguments.
The Nedelec class used 'degree' in a few places, but it was
really the 'order' of the element. The polynomial degree as
used in the base class is 'order+1'.
Wolfgang Bangerth [Fri, 4 Nov 2016 16:48:16 +0000 (10:48 -0600)]
Rename some variables.
There are variables of the same name in the base class. Avoid the
confusion of having similarly named variables in the local scope.
Daniel Arndt [Fri, 4 Nov 2016 16:24:42 +0000 (17:24 +0100)]
Merge pull request #3455 from masterleinad/fix_parpack_test
Fix parpack test
Timo Heister [Fri, 4 Nov 2016 14:38:20 +0000 (10:38 -0400)]
Merge pull request #3448 from davydden/matrix_free_Laplace_GMG_unit_test
add another matrix-free laplace GMG unit test
Daniel Arndt [Fri, 4 Nov 2016 14:13:24 +0000 (15:13 +0100)]
Merge pull request #3449 from drwells/pvs-timer-initialization
Add some missing initializations to Timer.
Daniel Arndt [Fri, 4 Nov 2016 13:57:06 +0000 (14:57 +0100)]
Fix parpack test
Daniel Arndt [Fri, 4 Nov 2016 12:49:48 +0000 (13:49 +0100)]
Make casts explicit, initialize all variables
Wolfgang Bangerth [Fri, 4 Nov 2016 13:43:55 +0000 (07:43 -0600)]
Initialize member variables.
Denis Davydov [Fri, 4 Nov 2016 13:43:51 +0000 (14:43 +0100)]
Merge pull request #3452 from bangerth/initialize-variables
Initialize member variables.
Wolfgang Bangerth [Fri, 4 Nov 2016 13:40:28 +0000 (07:40 -0600)]
Initialize member variables.
Wolfgang Bangerth [Thu, 3 Nov 2016 22:53:45 +0000 (16:53 -0600)]
Rename a function argument.
DataOutRotation::build_one_patch took a variable named 'patches',
but unlike in #3445, it is not a reference to the class's member
variable of the same name. Rather, it is an array this function
needs to fill in, and nobody else sees it. Consequently,
rename it 'my_patches'.
While there, also update the documentation, which is no longer
in agreement with the implementation.
Wolfgang Bangerth [Fri, 4 Nov 2016 13:13:41 +0000 (07:13 -0600)]
No need for double parentheses.
Denis Davydov [Fri, 4 Nov 2016 11:52:32 +0000 (12:52 +0100)]
do not require Trilinos for matrix_free tests which do not use it
Denis Davydov [Fri, 4 Nov 2016 11:47:14 +0000 (12:47 +0100)]
add another matrix-free laplace GMG unit test
David Wells [Fri, 4 Nov 2016 11:22:56 +0000 (07:22 -0400)]
Add some missing initializations to Timer.
Some of these were caught by PVS studio.
David Wells [Fri, 4 Nov 2016 10:55:24 +0000 (06:55 -0400)]
Merge pull request #3445 from bangerth/dont-duplicate-variable
Let DataOut::build_one_patch use a member variable.
David Wells [Fri, 4 Nov 2016 10:49:41 +0000 (06:49 -0400)]
Merge pull request #3444 from class4kayaker/static_fix
Fix FE_QHier static analysis warning
Wolfgang Bangerth [Fri, 4 Nov 2016 00:52:22 +0000 (18:52 -0600)]
Merge pull request #3434 from bangerth/initialize-member-variable
Initialize a member variable.
David Wells [Thu, 3 Nov 2016 23:17:58 +0000 (19:17 -0400)]
Merge pull request #3435 from bangerth/initialize-member-variable-2
Initialize member variables to invalid values.
Wolfgang Bangerth [Thu, 3 Nov 2016 22:34:08 +0000 (16:34 -0600)]
Let DataOut::build_one_patch use a member variable.
Currently, it takes a reference to a variable as argument, but this variable
is a member variable of the class to which it has access. That's duplicative.
To make things even more confusing, the local variable and the member
are named the same.
Fix this by just not taking the reference as argument, and directly
accessing the member of the class.
Wolfgang Bangerth [Thu, 3 Nov 2016 22:31:17 +0000 (16:31 -0600)]
Merge pull request #3439 from bangerth/simplify-computation
Simplify an initialization.
Wolfgang Bangerth [Thu, 3 Nov 2016 22:31:07 +0000 (16:31 -0600)]
Merge pull request #3437 from bangerth/be-careful-with-streams
Be more careful with streams.
Wolfgang Bangerth [Thu, 3 Nov 2016 22:30:59 +0000 (16:30 -0600)]
Merge pull request #3436 from bangerth/avoid-pointless-condition
Avoid a pointless comparison.
Jonathan Robey [Thu, 3 Nov 2016 21:26:55 +0000 (14:26 -0700)]
Fix FE_QHier static analysis warning
Fix to #3406
Denis Davydov [Thu, 3 Nov 2016 20:42:02 +0000 (21:42 +0100)]
Merge pull request #3442 from Rombur/add-assertthrow
Add a forgotten assert.
Bruno Turcksin [Thu, 3 Nov 2016 20:39:39 +0000 (16:39 -0400)]
Add a forgotten assert.
Bruno Turcksin [Thu, 3 Nov 2016 20:32:51 +0000 (16:32 -0400)]
Merge pull request #3441 from bangerth/initialize-variables-2
Initialize a member variable to invalid values.
David Wells [Thu, 3 Nov 2016 20:10:06 +0000 (16:10 -0400)]
Merge pull request #3431 from bangerth/make-variable-names-uniform
Make variable names uniform.
Daniel Arndt [Thu, 3 Nov 2016 18:47:22 +0000 (19:47 +0100)]
Merge pull request #3432 from bangerth/fix-blockvectorbase-memory_consumption
Fix BlockVectorBase::memory_consumption.
Wolfgang Bangerth [Thu, 3 Nov 2016 18:16:56 +0000 (12:16 -0600)]
Initialize a member variable to invalid values.
Wolfgang Bangerth [Thu, 3 Nov 2016 17:58:48 +0000 (11:58 -0600)]
Simplify an initialization.
Wolfgang Bangerth [Thu, 3 Nov 2016 17:56:41 +0000 (11:56 -0600)]
Be more careful with streams.
In particular, stop also if in.fail() is true, not just if in.eof() is true.
I suspect that it matters little in practice, but who knows.
Wolfgang Bangerth [Thu, 3 Nov 2016 17:55:03 +0000 (11:55 -0600)]
Avoid a pointless comparison.
The function works in 3d, so checking for 'dim>1' makes no difference.
Wolfgang Bangerth [Thu, 3 Nov 2016 17:45:24 +0000 (11:45 -0600)]
Initialize member variables to invalid values.
Wolfgang Bangerth [Thu, 3 Nov 2016 17:43:38 +0000 (11:43 -0600)]
Initialize a member variable.
Timo Heister [Thu, 3 Nov 2016 17:32:14 +0000 (13:32 -0400)]
Merge pull request #3433 from bangerth/fix-DataOut-memory_consumption
Update memory consumption output.
Wolfgang Bangerth [Thu, 3 Nov 2016 17:18:28 +0000 (11:18 -0600)]
Merge pull request #3394 from drwells/pvs-function-lib-warnings
Silence a PVS studio warning about repeated code.
In the beginning the Universe was created. This has made a lot of
people very angry and has been widely regarded as a bad move.
Douglas Adams
Typeset in
Trocchi and Trocchi Bold Sans Serif.